• Serverınızın epinlerini tamamen Turkmmo güvencesiyle satın. Kredi kartı, mobil ödeme, havale/eft ve uygun komisyon oranıyla. Hemen mağaza başvurunuzu yapın. Oyunalisveris.com





Sitemize reklam vermek için [email protected] adresine mail atabilirsiniz
For Advertising Contact [email protected]


Hangi FreeBSD sürümünü kullanmalıyım?

5.00 yıldız(lar) 3 Oy
  • Konbuyu başlatan Tungа
  • Başlangıç tarihi
  • Cevaplar 14
  • Görüntüleme 842

XxZeMaHSeRxX

Co-Administrator
Telefon Numarası Onaylanmış Üye TC Kimlik Numarası Doğrulanmış Üye
Co Admin
Yarışma
Paylaşım
Katılım
12 Tem 2017
Konular
3,368
Mesajlar
12,539
Reaksiyon Skoru
4,930
Online Süresi
230g 8s 7d
Başarım Puanı
430
Madalyalar
1
Yaş
18
MmoLira
1,623
DevLira
157
En İyi Cevap Puanı
75
Takipçiler
59
Eline sağlık. :)
Sabit.
 

enes dursun

C++ Developer
TM Üye
Üye
Katılım
2 Tem 2011
Konular
15
Mesajlar
255
Reaksiyon Skoru
25
Online Süresi
19g 20s 1d
Başarım Puanı
99
MmoLira
195
DevLira
3
En İyi Cevap Puanı
2
Takipçiler
0
@Tungа Eline sağlık hocam çok açıklayıcı bir anlatım olmuş bilmeyenler öğrenmiş oldu aradaki farkı ...
 

WalkingDeath

Slient Death..!
Uzman
Katılım
2 Şub 2013
Konular
89
Mesajlar
1,629
Reaksiyon Skoru
488
Başarım Puanı
177
MmoLira
641
DevLira
3
En İyi Cevap Puanı
3
Takipçiler
16
Bu çokca sorulan bir soru, cevabı ise çok basit; En son sürüm.

FreeBSD bir işletim sistemi ve sürüm güncellemeleri, kullanıcılar Metin2 oyunu açmaması için performans düşürelim diye yapılmıyor.
Çok yaygın olarak kullanılan 9.2 ile şuanda tüm global firmalar tarafından kullanılan 12 sürümü arasında dağlar kadar fark var. Bu farkların tamamı için Release Notes bölümünü okuyabilirsiniz.
Kullandığınız sürümden sonra yayınlanan release notes bir nevi hata çözümlemelerinin tamamını içerir. Bu nasıl hatalardır diye soracak olursanız, aslında Windows güncellemelerinden pek farklı değil. Windows'un güncellemeleri, hata ve çökme için çözümler, fonksiyonel geliştirmeler, performans geliştirmeleri, güvenlik geliştirmeleri gibi bir çok geliştirmeyi içerisinde barındırır. FreeBSD güncellemeleri için de aynısı söylenebilir. En son sürümde bu çözümlemeler tamamen yapılmış olmaktadır.

FreeBSD'nin en son sürümünde Metin2 çalışır mı?
Evet tabiki de çalışır. Tek yapmanız gereken gerekli kütüphane dosyalarını temin etmek. Statik derleme yapıyorsanız buna gerek bile yok.

FreeBSD'nin en son sürümünde Metin2 Build edilir mi?
Evet edilir. Derleyici(GCC/LLVM) ile birlikte GNU firmasının makefile oynatıcısı(Gmake) bulunuyorsa source build edebilirsiniz. Kütüphane dosyalarınızı da hazırlamayı unutmayın.

Neden insanlar FreeBSD 9.2 kullanıyor?
Mainline dosyalarının derlendiği kütüphane dosyaları içerisinde bulunan bir imaj olduğu için kullanılıyor. Bir artısı bulunmamakta.

Sen hangi sürüm kullanıyorsun?
Ben şuanda FreeBSD 11.3 64 Bit sürümünü kullanıyorum. Bu sürümde hem oyun çalıştırma hem derleme yapıyorum.

Bilişim firmaları neden en son sürümü sağlamıyor?
Bilişim firmalarının kullanıcılarına verdikleri imaj dosyalarını hazırladıkları esnada aktif olan sürüm, verdikleri sürüm olabilir. Bunun akla dayanır bir açıklaması yok.

Aklınıza takılan soruları konuda belirtirseniz konu içeriğine dahil ederim.





Oyunu çalıştırmak için sadece mysql gerekir.
Paket adı: mysql55-server
Source derlemek(build etmek) için ise derleyici(clang/gcc) ve gmake(makefile okuyucu) yeterli olur.
Paket adı:gcc9
Paket adı:gmake
Buna ilaveten depend kullanıyorsanız depend paketide gerekir.
Paket adı:makedepend

FreeBSD nin paket kütüphanesinden indireceğiniz boost, devIL, cryptopp gibi kütüphaneler sunucu dosyalarınız ile 1e1 uyumlu çalışmaz bu nedenle harici olarak bulundurmanız gerekir.
11.3 Sorunsuz Kuruldu Oyuna Giriş Başarılı Build İçin Hangi Komutları Kullanmamız Gerekiyor Yazarmısın Rica Etsem
Şuan gcc49 ile build ediyorum bunları kurdum

cd /usr/ports/devel/gmake && make DISABLE_VULNERABILITIES=yes install
cd /usr/ports/devel/makedepend && make DISABLE_VULNERABILITIES=yes install
cd /usr/ports/devel/subversion && make DISABLE_VULNERABILITIES=yes install
cd /usr/ports/graphics/devil && make DISABLE_VULNERABILITIES=yes install
cd /usr/ports/lang/gcc49 & make DISABLE_VULNERABILITIES=yes install

Başka Birşey Kurmaya Gerek varmı
 

TL Casper

Level 5
TM Üye
Katılım
18 Şub 2014
Konular
40
Mesajlar
623
Reaksiyon Skoru
63
Online Süresi
8g 23s 16d
Başarım Puanı
89
MmoLira
285
DevLira
0
En İyi Cevap Puanı
0
Takipçiler
3
Bu çokca sorulan bir soru, cevabı ise çok basit; En son sürüm.

FreeBSD bir işletim sistemi ve sürüm güncellemeleri, kullanıcılar Metin2 oyunu açmaması için performans düşürelim diye yapılmıyor.
Çok yaygın olarak kullanılan 9.2 ile şuanda tüm global firmalar tarafından kullanılan 12 sürümü arasında dağlar kadar fark var. Bu farkların tamamı için Release Notes bölümünü okuyabilirsiniz.
Kullandığınız sürümden sonra yayınlanan release notes bir nevi hata çözümlemelerinin tamamını içerir. Bu nasıl hatalardır diye soracak olursanız, aslında Windows güncellemelerinden pek farklı değil. Windows'un güncellemeleri, hata ve çökme için çözümler, fonksiyonel geliştirmeler, performans geliştirmeleri, güvenlik geliştirmeleri gibi bir çok geliştirmeyi içerisinde barındırır. FreeBSD güncellemeleri için de aynısı söylenebilir. En son sürümde bu çözümlemeler tamamen yapılmış olmaktadır.

FreeBSD'nin en son sürümünde Metin2 çalışır mı?
Evet tabiki de çalışır. Tek yapmanız gereken gerekli kütüphane dosyalarını temin etmek. Statik derleme yapıyorsanız buna gerek bile yok.

FreeBSD'nin en son sürümünde Metin2 Build edilir mi?
Evet edilir. Derleyici(GCC/LLVM) ile birlikte GNU firmasının makefile oynatıcısı(Gmake) bulunuyorsa source build edebilirsiniz. Kütüphane dosyalarınızı da hazırlamayı unutmayın.

Neden insanlar FreeBSD 9.2 kullanıyor?
Mainline dosyalarının derlendiği kütüphane dosyaları içerisinde bulunan bir imaj olduğu için kullanılıyor. Bir artısı bulunmamakta.

Sen hangi sürüm kullanıyorsun?
Ben şuanda FreeBSD 11.3 64 Bit sürümünü kullanıyorum. Bu sürümde hem oyun çalıştırma hem derleme yapıyorum.

Bilişim firmaları neden en son sürümü sağlamıyor?
Bilişim firmalarının kullanıcılarına verdikleri imaj dosyalarını hazırladıkları esnada aktif olan sürüm, verdikleri sürüm olabilir. Bunun akla dayanır bir açıklaması yok.

Aklınıza takılan soruları konuda belirtirseniz konu içeriğine dahil ederim.





Oyunu çalıştırmak için sadece mysql gerekir.
Paket adı: mysql55-server
Source derlemek(build etmek) için ise derleyici(clang/gcc) ve gmake(makefile okuyucu) yeterli olur.
Paket adı:gcc9
Paket adı:gmake
Buna ilaveten depend kullanıyorsanız depend paketide gerekir.
Paket adı:makedepend

FreeBSD nin paket kütüphanesinden indireceğiniz boost, devIL, cryptopp gibi kütüphaneler sunucu dosyalarınız ile 1e1 uyumlu çalışmaz bu nedenle harici olarak bulundurmanız gerekir.
Teşekkürler hocam bende sizin kullandığınız FreeBSD 11.3 64 Bit kullanmak istiyorum bu sürüme mysql 5.5 kurabiliyor muyuz desteği var mı kurması kolay mı hatalarla vs karşılaşır mıyız
 

Şu an konuyu görüntüleyenler (Toplam : 1, Üye: 0, Misafir: 1)

Üst